Вопрос по информатике:
Напишите программу для Паскаля для перестановки максимального и минимального по значению элементов массива. Значения длины массива вводятся с клавиатуры
- 17.03.2018 18:10
- Информатика
- remove_red_eye 13279
- thumb_up 44
Ответы и объяснения 1
n,i,min,imin,max,imax:integer;
begin
write('n = ');
readln(n);
SetLength(a,n);
for i:=0 to n-1 do
begin
a[i]:=random(51);
write(a[i]:4);
end;
writeln;
min:=a[0]; imin:=0;
max:=a[0]; imax:=0;
for i:=1 to n-1 do
begin
if a[i]
min:=a[i]; imin:=i;
end;
if a[i]>max then
begin
max:=a[i]; imax:=i;
end
end;
writeln('min = ',min,' max = ',max);
a[imin]:=max; a[imax]:=min;
for i:=0 to n-1 do write(a[i]:4);
writeln;
end.
Пример:
n = 10
33 17 33 49 3 2 14 25 35 47
min = 2 max = 49
33 17 33 2 3 49 14 25 35 47
- 18.03.2018 23:12
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.