Вопрос по информатике:
Pascal abc
составить программу для нахождения S
Дано натуральное число n. Найти сумму S=1- 1/5 + 1/9 - 1/13...+ (n-слагаемых)
Спасибо!
- 06.03.2015 03:10
- Информатика
- remove_red_eye 18276
- thumb_up 37
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('n=');
Writeln(Range(0,n-1).Select(i->1/(i.IsEven?4*i+1:-(4*i+1))).Sum)
end.
Пример
n= 13
0.876761945581588
для Pascal ABC (проверить негде, проект закрыт в 2004 году)
var
i,n,z:integer;
x,s:real;
begin
Write('n='); Read(n);
s:=0; z:=1;
for i:=0 to n-1 do begin
x:=1/(4*i+1);
s:=s+x*z;
z:=-z
end;
Writeln(s)
end.
- 07.03.2015 10:58
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.