Вопрос по информатике:
Составьте программу которая заполняет массив b1..8 случайными целыми числами в диапазоне от 1 до 10 и находит произведение элементов с нечетными значениями и количеством элементов с четными значениями
помогите хоть каким решением
- 24.11.2017 01:52
- Информатика
- remove_red_eye 19898
- thumb_up 45
Ответы и объяснения 1
var b:array[1..8] of integer;
i, n, p, f:integer;
begin
p:=1;
f:=1;
writeln('Введите кол-во элементов');
readln(n);
for i:=1 to n do
begin
b[i]:=random(10)+1;
write(b[i],' ');
If i mod 2=0 then p:=p*b[i];
If i mod 20 then f:=f*b[i];
end;
writeln('p=',p);
writeln('f=',f);
end.
- 25.11.2017 07:47
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.