Вопрос по информатике:
Помогите пожалуйста составить программу в паскаль.
Дана последовательность из 10 чисел (2,3,-15,4.4,0,-3.2,3,25,-5,0). Найти произведение положительных элементов и количество отрицательных элементов.
- 10.07.2018 01:34
- Информатика
- remove_red_eye 12714
- thumb_up 34
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(2.0,3.0,-15.0,4.4,0.0,-3.2,3.0,25.0,-5.0,0.0);
a.Println;
Writeln('Произведение положительных= ',
a.Where(t->t>0).Aggregate(1.0,(x,y)->x*y));
Writeln('Количество отрицательных= ',a.Where(t->t<0).Count)
end.
Результат
2 3 -15 4.4 0 -3.2 3 25 -5 0
Произведение положительных= 1980
Количество отрицательных= 3
- 11.07.2018 09:12
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.