Вопрос по информатике:
Составить программу для решения квадратного уравнения a*x*x+b*x+c=0
- 07.10.2017 16:38
- Информатика
- remove_red_eye 5785
- thumb_up 20
Ответы и объяснения 1
a, b, c, D: integer;
x, x2: real;
begin
write('Введите a: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
D := sqr(b) - 4 * a * c;
if D > 0 then begin
x := (-b - sqrt(D)) / 2 * a;
x2 := (-b + sqrt(D)) / 2 * a;
writeln('x1 = ', x, newline, 'x2 = ', x2);
end;
if D < 0 then writeln('Корней нет.');
if D = 0 then begin
x := (-b) / 2 * a;
writeln('x = ', x);
end;
end.
- 08.10.2017 18:30
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.