Вопрос по информатике:
СРОЧНО!!!в массиве 8 элементов напишите программу которая находит сумму положительнух чмсел и кол во чисел =0
- 27.12.2017 23:33
- Информатика
- remove_red_eye 6791
- thumb_up 48
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(8,-9,9); a.Println;
Writeln('Сумма положительных ',a.Where(t->t>0).Sum);
Writeln('Количество нулей ',a.Where(t->t=0).Count)
end.
Пример
2 6 -6 7 0 2 3 6
Сумма положительных 26
Количество нулей 1
- 28.12.2017 21:18
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.