Вопрос по информатике:
Составить программу формирования массива из 50 элементов, в которой используется признак Р, в зависимости от значения которого реализовывался бы один из способов задания массива: при Р= -1 с помощью генератора случайных чисел, при Р=0 с помощью формулы А[i] = i +101, при Р=1 с клавиатуры. Сделать вывод сформированного массива на экран.
- 10.07.2015 00:21
- Информатика
- remove_red_eye 5565
- thumb_up 37
Ответы и объяснения 1
var a: array[1..n] of integer;
p,i: integer;
begin
write('p (-1,0,1) = ');
readln(p);
case p of
1: for i:=1 to n do a[i]:=random(100);
0: for i:=1 to n do a[i]:=i+101;
-1: begin for i:=1 to n do read(a[i]); readln; end;
end;
writeln;
writeln('Исходный массив:');
for i:=1 to n do write(a[i],' ');
writeln;
end.
Пример (для n=5):
p (-1,0,1) = 0
Исходный массив:
102 103 104 105 106
- 01.01.1970 00:00
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.