Вопрос по информатике:
Среди первых трёх элеметов найдите максимальный элемент и его индекс. Среди последних трёх элементов найдите минимальный элемент и его индекс . Результат выведите на экран . Паскаль
- 08.09.2017 16:20
- Информатика
- remove_red_eye 7896
- thumb_up 18
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
var s:=a.Select((v,i)->(v,i)); // последовательность в памяти не хранится
var max:=s.Take(3).Max(t->t[0]);
var imax:=a.IndexesOf(t->t=max).First;
var min:=s.TakeLast(3).Min(t->t[0]);
var imin:=a.IndexesOf(t->t=min).Last;
Writeln('Максимальный из первых трех - №',imax+1,': ',a[imax]);
Writeln('Минимальный из последних трех - №',imin+1,': ',a[imin]);
end.
Пример:
n= 17
-34 37 26 41 19 24 19 4 -7 -31 5 -23 -40 -40 -31 -28 -12
Максимальный из первых трех - №2: 37
Минимальный из последних трех - №15: -31
- 10.09.2017 00:31
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.