Вопрос по информатике:
Даю 75 баллов! Напишите программу, которая в списке из десяти случайных целочисленных элементов из диапазона от 0 до 100 находит максимальный чётный и минимальный нечётный элементы.
- 18.06.2015 22:48
- Информатика
- remove_red_eye 3002
- thumb_up 35
Ответы и объяснения 2
Версия 3.3. сборка 1583 (25.11.2017)
var a:array[1..10] of integer;
begin
var max:=2;
var min:=101;
for var i:=1 to 10 do
begin
a[i]:=random(0,100);
write(a[i],' ');
if (a[i] mod 2=0) and (a[i]>max)
then max:=a[i];
if (a[i] mod 2=1) and (a[i]
end;
writeln;
writeln('Минимальный нечетный елемент - ',min);
writeln('Максимальный четный елемент - ',max);
readln;
end.
- 19.06.2015 15:31
- thumb_up 10
var
A: array [1..10] of byte;
i, min, max: byte;
begin
randomize;
min := 101; max := 0;
for i := 1 to 10 do
begin
A[i] := random(101);
if ((A[i] < min) and (A[i] mod 2 0)) then min := A[i];
if ((A[i] > max) and (A[i] mod 2 = 0)) then max := A[i];
write(A[i], ' ');
end;
writeln;
writeln('Максимальный четный = ', max);
writeln('Минимальный нечетный = ', min);
readln;
end.
- 20.06.2015 17:40
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.