Вопрос по информатике:
Напишите программу, которая получает два целых числа (A и B) и находит их
произведение, не используя операцию умножения. Учтите, что числа могут быть
отрицательными.
Формат входных данных
В первой строке входных данных - два числа A и B (-10000 пробел
Формат выходных данных
Cтрока содержащее произведение чисел (см. пример вывода)
Пример
Входные данные Выходные данные
10 -15 10*(-15)=-150
- 21.01.2018 19:23
- Информатика
- remove_red_eye 17906
- thumb_up 47
Ответы и объяснения 1
int main(){ int a, b,f=0,f1=0,ans=0; cin >> a >> b; if (a < 0 ) f = 1; if (b < 0) f1 = 1; for (int i = 0; i < abs(b);i++) { ans += a; } if (f == 1 && f1 == 1) cout << abs(ans); else if (f == 1 || f1 == 1) cout << '-' << abs(ans); else cout << ans; return 0;}
- 22.01.2018 04:30
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.