Вопрос по информатике:
Помогите пожалуйста!!! Задача на Paskal
Напишите программу, которая вычесляет среднюю температуру воздуха за 10 дней, выведит на экран max и min значение температуры. Данные вводятся с клавиатуры.
- 21.08.2017 14:50
- Информатика
- remove_red_eye 9877
- thumb_up 29
Ответы и объяснения 1
var
a: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i,k: integer;
min,max: real;
begin
k:=0;
N:= 10;
for i:=1 to N do begin
read(a[i]);
k:=k+a[i];
end;
write('Вывод элементов массива: ');
for i:=1 to N do
write(a[i],' ');
min := a[1];
for i:=2 to N do
if a[i]
min := a[i];
end;
max := a[1];
for i:=2 to N do
if a[i]>max then
begin
max := a[i];
end;
writeln('max=',max,' ','min=', min,' ','Средная температура=',k/N)
end.
- 22.08.2017 07:21
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.