Вопрос по информатике:
ПРОШУ ПОМОГИТЕ, ОЧЕНЬ НУЖНО!!
ИНФОРМАТИКА 10 КЛАСС, PASCAL.
Дана строка, содержащая два слова, разделенные дефисом. написать программу, добавляющую пробел до и после дефиса
- 12.05.2018 17:54
- Информатика
- remove_red_eye 8453
- thumb_up 37
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString;
var p:=Pos('-',s);
if p>0 then begin s:=s.Replace('-',' - '); Writeln(s) end
else Writeln('Дефис не найден')
end.
Пример
черно-белый
черно - белый
- 13.05.2018 23:41
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.