Вопрос по информатике:
Задание 1. Дана программа нахождения суммы и произведения первых 10-и натуральных чисел
Составьте программу нахождения суммы и произведения первых 20-и четных чисел.
program pr_1;
var i, s, p: integer;
begin
s:=0;
p:=1;
for i:=1 to 10 do
begin
s:=s+i;
p:=p*i
end;
writeln ('сумма чисел равна ', s);
writeln ('произведение чисел равно ', p)
end.
program pr_2;
var i, s, p: integer;
begin
s:=0;
p:=1;
i:=1;
while i<=10 do
begin
s:=s+i;
p:=p*i;
i:=i+1
end;
writeln ('сумма чисел равна ', s);
writeln ('произведение чисел равно ', p)
end.
- 27.04.2016 06:53
- Информатика
- remove_red_eye 17827
- thumb_up 22
Ответы и объяснения 1
var i, s: integer;
p: real;
begin
s:=0;
p:=1;
for i:=1 to 20 do
if i mod 2 = 0 then
begin
s:=s+i;
p:=p*i;
end;
writeln('Сумма четных чисел: ', s);
writeln('Произведение четных чисел: ', p);
end.
//С циклом while
var i, s: integer;
p: real;
begin
s := 0;
p := 1;
i := 1;
while i <= 20 do
begin
if i mod 2 = 0 then
begin
s:=s+i;
p:=p*i;
end;
i := i + 1;
end;
writeln('Сумма четных чисел: ', s);
writeln('Произведение четных чисел: ', p);
end.
- 29.04.2016 00:04
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.