Вопрос по информатике:
Помогите с заданием на языке Pascal
Используя оператор условного перехода, напишите программу,
которая: запрашивает с клавиатуры два целых числа, их сумму и произведение и выводит на экран сооб-
щение о правильности сделанных пользователем вычислений;
- 09.05.2018 04:44
- Информатика
- remove_red_eye 10794
- thumb_up 41
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b):=ReadReal2('Введите два числа через пробел:');
var (s1,p1):=ReadReal2('Введите через пробел из сумму и произведение:');
var (s2,p2):=(a+b,a*b);
if s1=s2 then Writeln('Сумма верна')
else Writeln('Сумма не верна, ',s2);
if p1=p2 then Writeln('Произведение верно')
else Writeln('Произведение не верно, ',p2)
end.
Пример
Введите два числа через пробел: 1.4 -2.5
Введите через пробел из сумму и произведение: -1.1 -3.25
Сумма верна
Произведение не верно, -3.5
- 01.01.1970 00:00
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.