Вопрос по информатике:
Винни-Пуху прислали посылку – K литров мёда. Сначала он попытался разлить его в бочонки по 2 литра, но вот незадача - 1 литр остался. Потом попытался разлить в бочонки по 3 литра, и опять осталось 2 литра. И так далее, пока он не разлил мёд в бочонки по N литров, и у него осталось N-1 литров мёда. Определите, какое минимальное количество мёда могли прислать Винни.
Формат входных данных:
Строка, содержащая целое число N (2≤N≤19).
Формат выходных данных:
Вывести требуемое число K.
- 03.11.2017 03:35
- Информатика
- remove_red_eye 1721
- thumb_up 13
Ответы и объяснения 1
begin
readln(n);
k:=1;
f:=false;
while not f do
begin
k:=k+1;
f:=true;
for i:=2 to n do
f:=f and (k mod i=i-1);
end;
writeln(k);
end.
Пример (для 19 долго считает, можно оптимизировать, если нужно):
19
232792559
- 04.11.2017 07:38
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.