Вопрос по информатике:
Помогите, пожалуйста, составить программу, определяющую, какая из букв "Е" или "О" встречается чаще в предложении. Если можно, то с объяснением. Даю 25 баллов.
- 16.07.2018 09:26
- Информатика
- remove_red_eye 16237
- thumb_up 44
Ответы и объяснения 2
s:string;
begin
ko:=0;
ke:=0;
readln(s);
for i:=1 to length(s) do begin
if (s[i]='Е') or (s[i]='е') then ke:=ke+1;
if (s[i]='О') or (s[i]='о') then ko:=ko+1;
end;
if ko>ke then writeln('К встречается чаще') else writeln('О встречается чаще');
end.
- 17.07.2018 08:39
- thumb_up 4
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString.ToUpper; // к верхнему регистру
var (kO,kE):=(0,0); // счетчики
for var i:=1 to s.Length do
case s[i] of
'О':ko+=1;
'Е':kE+=1
end;
if kO>kE then Writeln('Буква "О" встречается чаще')
else if kO
end.
Пример
Если бы Ольга захотела, она бы училась лучше Елены
Буква "Е" встречается чаще
- 18.07.2018 20:41
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.