Вопрос по информатике:
Компьютер перебирает четные числа до тех пор пока сумма их квадратов не привысет n. чему равна сумма квадратов?pascal
- 05.08.2018 14:04
- Информатика
- remove_red_eye 17984
- thumb_up 27
Ответы и объяснения 2
label 1;
var i,n,s:longint;
begin
write('Write n: '); readln(n);
s:=0;
for i:=1 to 10000 do
begin
if s
If i mod 2=0
then
s:=s+sqr(i)
else
goto 1
else
break;
1:
end;
writeln(s);
readln
end.
- 06.08.2018 18:04
- thumb_up 30
begin
readln(n);
a:=0;
s:=0;
while s<=n do
begin
a:=a+2;
s:=s+a*a;
end;
writeln('s = ',s);
end.
Пример:
500
s = 560
- 07.08.2018 18:53
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.