Вопрос по информатике:
Напишите программу выводящую индекс наименьшего числа 3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81
- 24.02.2018 20:39
- Информатика
- remove_red_eye 1615
- thumb_up 34
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
var a:=Arr(3,9,1,3,5,8,5,3,6,7,6,5,4,6,1,81); a.Println;
a.IndexesOf(t->t=a.Min).Select(t->t+1).Println
end.
Результат
3 9 1 3 5 8 5 3 6 7 6 5 4 6 1 81
3 15
- 25.02.2018 10:50
- thumb_up 42
var i,n,k,min:integer;
a:array[1..1000] of integer;
begin
write('Write size array: '); readln(n);
for i:=1 to n do
read(a[i]);
min:=a[1];
for i:=1 to n do
if min>a[i]
then begin min:=a[i]; k:=i; end;
writeln(k);
end.
- 27.02.2018 00:18
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.