Вопрос по информатике:
В ПАСКАЛЕ И ТОЛЬКО В ПАСКАЛЕ.
1)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке не убывания.
2)дан массив десяти целых чисел напишите программу которая выводит элементы массива в порядке убывания , а также выводит количество перестановок.
3)дан массив десяти целых чисел. Найти медиану числового ряда.
4) Дан массив десяти целых чисел выведите минимальное число массива оканчиговающегося на 4
5) дан массив десяти целых чисел напишите программу которая выводит на экран на экран максимальное число кратное 5.
- 18.01.2015 17:32
- Информатика
- remove_red_eye 18866
- thumb_up 29
Ответы и объяснения 1
var i,n,k:integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
read(a[i]);
writeln;
for i:=10 downto 1 do
write(a[i],' ');
readln;
readln
end.
3)
var i,n,k:integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
read(a[i]);
writeln;
writeln((a[5]+a[6])/2:0:2);
readln;
readln
end.
4)
var i,n,k,min:integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
begin
read(a[i]);
if (a[i] mod 10=4) or (a[i] mod 10=-4)
then min:=a[i];
for i:=1 to 10 do
if ((a[i] mod 10=4) or (a[i] mod 10=-4)) and (a[i]
writeln(min);
end.
5)
var i,n,k,max:integer;
a:array[1..10] of integer;
begin
max:=0;
for i:=1 to 10 do
begin
read(a[i]);
if (a[i] mod 5=0) and (a[i]>max)
then max:=a[i];
end;
writeln(max);
end.
- 19.01.2015 13:22
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.