Вопрос по информатике:
Составить программу для вычисления суммы факториалов всех четных чисел от m до n.(Matlab)
- 12.10.2015 21:53
- Информатика
- remove_red_eye 13410
- thumb_up 15
Ответы и объяснения 1
i,m,n,s:integer;
function fact(a:integer):integer;
var l:integer;
begin
l:=1;
for i:=2 to a do
l:=l*i;
fact:=l;
end;
begin
read(m);
readln(n);
s:=0;
for i:=m to n do
if i mod 2=0
then s:=fact(i)+s;
writeln('Suma: ',s);
end.
- 13.10.2015 22:31
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.