Вопрос по информатике:
Pascal Вывести для каждого заданного числа количество цифр.
Формат ввода:
Элементы последовательности (целые числа в диапазоне от -30000 до 30000) заданы по одному на строке через пробел. Признак окончание последовательности - число 0 (в последовательность не входит).
Формат вывода:
Целое число.
Пример входных данных
1 -23 -31 486 0
Пример выходных данных
1223
- 10.09.2015 15:37
- Информатика
- remove_red_eye 19280
- thumb_up 17
Ответы и объяснения 1
i,n,k:longint;
a:array [1..30000] of longint;
begin
n:=0;
for i:=1 to 30000 do
begin
read(a[i]);
if a[i]0
then n:=n+1
else break;
end;
for i:=1 to n do
begin
k:=0;
while a[i]0 do
begin
a[i]:=a[i] div 10;
k:=k+1;
end;
writeln(k,' ');
end;
end.
- 11.09.2015 13:50
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.