Вопрос по информатике:
ДАЮ 30 БАЛЛОВ.РЕШИТЕ ЗАДАЧУ ПО ОЛИМПИАДЕ ПО ИНФОРМАТИКЕ!!!
Решите задачу по олимпиаде информатика 9 класс.
Дан массив А размера N. Найти минимальный элемент из его элементов с четными номерами A2, A4, A6, ..
Входные данные. Вводится одно натуральное число размер массива
Выходные данные. Выводятся одно число - минимальный элемент среди элементов с четными номерами (если несколько элементов имеют одинаковое значение вывести первый из них)
Пример ввода | Пример вывода
1 2 5 6 8 | 2
0 5 1 3 9 8 | 3
- 22.09.2017 04:36
- Информатика
- remove_red_eye 897
- thumb_up 10
Ответы и объяснения 1
Var n,i,k,min:integer;
a:array[1..1000] of integer;
Begin
readln(n);
for i:=1 to n do
read(a[i]);
min:=a[2];
for i:=2 to n do
if i mod 2=0
then
if a[i]
writeln(min);
End.
- 23.09.2017 14:10
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.