Вопрос по информатике:
Помогите, sos!!!
1. Составить программу, которая формирует массив из 15 случайных чисел от -20 до 20 и четные числа возводит в квадрат. На экран выводятся исходные данные и преобразованные значения через 4 пробела.
2. Составить программу, которая формирует массив из 10 целых чисел, элементы массива вводятся вручную с клавиатуры. Поменять местами первый и последний элементы массива и вывести на экран.
- 02.03.2018 18:03
- Информатика
- remove_red_eye 18385
- thumb_up 10
Ответы и объяснения 1
Program arrays;
const n = 15;
Var a:array [1..n] of integer;
i:integer;
begin
for i:=1 to n do a[i]:= random(-20, 20);
for i:=1 to n do
begin
if a[i] mod 2 = 0 then
a[i]:=sqr(a[i]);
end;
for i:= 1 to n do write(a[i], ' ');
end.
2.
Program arrayss;
const n = 10;
Var a:array [1..n] of integer;
i:integer;
begin
for i:=1 to n do read(a[i]);
swap(a[1], a[10]);
for i:= 1 to n do write(a[i], ' ');
end.
- 03.03.2018 16:21
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.