Вопрос по информатике:
Напишите программу для суммы числового ряда.
Дан числовой ряд и малая величина е(эпсила). Найдите сумму ряда с точностью е(0,001), общий член которого задан формулой:
- 17.11.2015 19:53
- Информатика
- remove_red_eye 10610
- thumb_up 43
Ответы и объяснения 1
//Функция факториала
function fact(n: integer): real;
begin
if (n = 0) then fact := 1
else fact := n * fact(n - 1);
end;
//Main
var
a: real;
x, lim: integer;
begin
write('Введите x: '); readln(x);
lim := x; a := 0;
for x := 1 to lim do
begin
//a := a + (power(2, x) * fact(x))/(power(x, x));
a := a + ((exp(ln(2) * x)) * fact(x))/(exp(ln(X) * x));
end;
writeln('a = ', a:5:3);
readln;
end.
- 18.11.2015 02:52
- thumb_up 46
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.