Вопрос по информатике:
Задан двумерный массив С из 4-х строк и 4-х столбцов (квадратная матрица). Составить программу подсчёта суммы всех отрицательных элементов и суммы элементов по главной диагонали. Помогите пожалуйста :3
- 13.03.2018 04:41
- Информатика
- remove_red_eye 19415
- thumb_up 34
Ответы и объяснения 2
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('*** Исходный массив ***');
var a:=MatrRandom(4,4,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
var sn:=a.ElementsByRow.Where(t->t<0).Sum;
Writeln('Сумма отрицательных элементов равна ',sn);
var sd:=0;
for var i:=0 to a.RowCount-1 do sd+=a[i,i];
Writeln('Сумма элементов на главной диагонали равна ',sd);
end.
Пример
*** Исходный массив ***
55 -36 70 19
79 14 5 -5
79 -9 -62 20
-71 69 -34 66
----------------
Сумма отрицательных элементов равна -217
Сумма элементов на главной диагонали равна 73
- 15.03.2018 07:09
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.