Вопрос по информатике:
Составить программу в Pascal, которая в тексте после каждой буквы вставляет заданный символ (с помощью стандартных процедур)
- 21.10.2017 07:06
- Информатика
- remove_red_eye 17364
- thumb_up 28
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadlnString('Введите текст:');
var c:=ReadlnChar('Введите букву для вставки');
var s1:='';
for var i:=1 to s.Length do begin
s1+=s[i];
if s[i]' 'then s1+=c
end;
Writeln(s1)
end.
Пример
Введите текст: Привет паскалю!
Введите букву для вставки Ы
ПЫрЫиЫвЫеЫтЫ пЫаЫсЫкЫаЫлЫюЫ!Ы
- 22.10.2017 20:16
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.