Вопрос по информатике:
Написать программу, которая переводит из двоичной в десятичную систему счисления на С# или С.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 12.09.2015 04:01
- Информатика
- remove_red_eye 17217
- thumb_up 34
Ответы и объяснения 1
public class Test
{
public static void Main()
{
int n=0, d=1;
Console.WriteLine("Введите двоичное число: ");
string s = Console.ReadLine();
for (int i=0; i
d *= 2;
}
Console.WriteLine("n = {0}", n);
Console.ReadKey();
}
}
Пример:
Введите двоичное число: 1110111
n = 119
- 13.09.2015 00:47
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.