Вопрос по информатике:
Задача по программированию на Паскаль, нужна помощь.
Дана строка состоящая из строчных букв английского алфавита. Необходимо определить какие буквы встречаются в этой строке больше одного раза.
Формат входных файлов: Входной файл содержит одну строку S длиной не более чем 100 символов, состоящую из букв a,b,c...
Выходной файл должен содержать в алфавитном порядке последовательность букв строки S, которые встречаются в ней больше одного раза. Каждая буква выводится не больше одного раза.
- 10.07.2016 00:44
- Информатика
- remove_red_eye 14628
- thumb_up 24
Ответы и объяснения 2
s:string;
k:array['a'..'z']of integer;
i:integer; c:char;
begin
assign(t1,'input.txt');
reset(t1);
assign(t2,'output.txt');
rewrite(t2);
readln(t1,s);
for c:='a' to 'z' do k[c]:=0;
for i:=1 to length(s) do k[s[i]]:=k[s[i]]+1;
for c:='a' to 'z' do
if k[c]>1 then write(t2,c);
writeln(t2);
close(t1); close(t2);
end.
Пример:
Файл input.txt:
xyzabcdefgabcdx
Файл output.txt
abcdx
- 11.07.2016 14:25
- thumb_up 41
// Внимание! Если программа не работает, обновите версию!
begin
var s:=ReadAllText('input.txt');
WriteAllText('output.txt',s.GroupBy(c->c).Select(t->(t.Key,t.Count))
.Where(t->t[1]>1).Select(t->t[0]).OrderBy(t->t).JoinIntoString(''))
end.
Пример
Во входном файле input.txt записана строка
petrwpoqwwefrnmvndihbgfuiusbnyaysinrivniweuwepkwqeofkwpr
В выходном файле output.txt будет получена строка
befiknopqrsuvwy
- 12.07.2016 17:08
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.