Вопрос по информатике:
Помогите пожалуйста. Задания Составить программу которая выводит на экран все чёрные числа то 2 до 20 Delphi
- 22.08.2018 10:56
- Информатика
- remove_red_eye 13931
- thumb_up 33
Ответы и объяснения 1
№3. program ex3;
var a,b:string;
k,n,i:integer;{ввод исходных данных}
begin
writeln('введите первое слово');
readln(a); {компьютер читает введенное число a}
writeln('введите второе слово');
readln(b); {компьютер читает введенное число b}
k:=0; {обнуляем переменные k и n, это будут счетчики в данной программе}
n:=0;
for i:=1 to length(a) do { проверяем символы от первого до конца строки}
k:=k+1; {если в строке находится символ, то переменная k увеличивается на 1}
for i:=1 to length(b) do {аналогично}
n:=n+1;
if k>n {проверяем, если количество символов в первой строке больше, чем количество символов во второй, то выводим a(первое слово), иначе b (второе слово)}
then
writeln(a)
else
writeln(b);
end.
№4program ex4;
var a,b:string;
i:integer;
begin
writeln('введите первое слово');
readln(a);
writeln('введите второе слово');
readln(b);
k:=0;
n:=0;
for i:= length(a) downto 1 do {просматриваю строку в обратном порядке и вывожу каждый символ на экран}
write(a[i]);
writeln;
for i:=length(b) downto 1 do {просматриваю строку в обратном порядке и вывожу каждый символ на экран}
write(b[i]);
end.
№5
program ex3;
var a:string;
k,n,i:integer;{ввод исходных данных}
begin
writeln('введите слово');
readln(a); {компьютер читает введенное число a}
k:=0; {обнуляем переменные k , это будут счетчики в данной программе}
for i:=1 to length(a) do { проверяем символы от первого до конца строки}
k:=k+1; {если в строке находится символ, то переменная k увеличивается на 1}
writeln(k);
end.
№6. Задача аналогичная №3, за исключением условия в конце.
program ex3;
var a,b:string;
k,n,i:integer;{ввод исходных данных}
begin
writeln('введите первое слово');
readln(a); {компьютер читает введенное число a}
writeln('введите второе слово');
readln(b); {компьютер читает введенное число b}
k:=0; {обнуляем переменные k и n, это будут счетчики в данной программе}
n:=0;
for i:=1 to length(a) do { проверяем символы от первого до конца строки}
k:=k+1; {если в строке находится символ, то переменная k увеличивается на 1}
for i:=1 to length(b) do {аналогично}
n:=n+1;
if k
writeln(a)
else
writeln(b);
end.
- 23.08.2018 06:47
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.