Вопрос по информатике:
Массив R[1]=12, R[2]=3, R[3]=-5, R[4]= -6, R[5]=4, R[6]=9, R[7]=0, R[8]=8. Определите значение суммы после выполнения следующего фрагмента программы: sum:=0; for i:=3 to 7 do if r[i]>5 sum:=sum+r[i]; writeln (sum);
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 26.06.2015 02:47
- Информатика
- remove_red_eye 8192
- thumb_up 42
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:array of integer := (0,12,3,-5,-6,4,9,0,8);
var sum:= 0;
for var i := 3 to 7 do
if a[i]>5 then
sum:=sum+a[i];
writeln (sum);
end.
Ответ: 9
- 27.06.2015 10:43
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.