Вопрос по информатике:
Помогите пожалуйста написать программу в С++, подсчитывающую количество символов в заданной строке. Ответ должен быть развёрнутым.Строку вводит пользователь.
Пример
Строка: Мама мыла раму
В строке: "Мама мыла раму" символов: 14
- 27.09.2017 13:30
- Информатика
- remove_red_eye 15107
- thumb_up 14
Ответы и объяснения 1
// Количество символов для русского языка считает корректно, но вывод самой строки и работа со строкой не возможна.
#include
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
char s[1000]; int ans = 0;
cin.getline(s,1000, '\n');
string s1 = string(s);
cout << "Строка: " << s << endl;
cout << "В строке: <<" << s1 <> ";
cout << s1.length() << " символов";
}
Пример:
For my heart
Строка: For my heart
В строке: <> 12 символов
- 29.09.2017 00:39
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.