Вопрос по информатике:
Напишите программу, которая получает два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными только на С++
- 13.11.2017 19:34
- Информатика
- remove_red_eye 4838
- thumb_up 28
Ответы и объяснения 1
using namespace std;
int main()
{
int n, m;
cin >> n >> m;
int ans = 0;
if (n != 0 && m!=0)
for (int i = 0; i < abs(m); i++)
ans += n;
if (n != 0 && m!=0) cout << ans / (abs(m)/m);
else cout << 0;
}
- 14.11.2017 13:43
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.