Вопрос по информатике:
Помогите пожалуйста, нужно очень срочно. Надо написать программу на PascalABCNET, которая создаёт типизированный файл из 40 вещественных чисел. Расположенны они по такому принципу: первые 10- положительные, вторые 10- отрицательные, третьи 10- полижетельные, четвёртые 10- отрицательные (Пример: 1 2 3 4 5 6 7 8 9 10 -11 -12 -13 -14 -15 -16 -17 -18 -19 -20 21 22 23 24...) Нужно создать новый типизированный файл, в котором эти же числа будут расположены следующим образом: первые 5- положительные, вторые 5- отрицательные, третьи 5 - положительные и так далее.
- 18.08.2018 17:57
- Информатика
- remove_red_eye 8165
- thumb_up 7
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
Нулевой шаг: создание типизированного файла нужной структуры
begin
var f:file of real;
Assign(f,'MyReal.bin'); Rewrite(f);
loop 2 do begin
SeqRandomInteger(10,1,100).Select(t->t/10).ForEach(t->Write(f,t));
SeqRandomInteger(10,-100,-1).Select(t->t/10).ForEach(t->Write(f,t));
end;
f.Seek(0); // начало файла
var b:real;
while not Eof(f) do begin Read(f,b); Print(b) end;
Println;
f.Close
end.
Пример:
9.7 1 4.1 8.3 5.6 9.3 2.2 9.3 5.8 8.8 -8.8 -7.7 -1.4 -5.2 -7.2 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 4.5 10 4.5 6.1 0.7 -8 -0.8 -3.3 -9.5 -7.9 -0.9 -7.4 -9.4 -1.8 -4.6
Собственно, программа
begin
var f1,f2:file of real;
Assign(f1,'MyReal.bin'); Reset(f1);
if f1.FileSize mod 200 then begin
Writeln('Количество компонент во входном файле не кратно 20');
Exit
end;
Assign(f2,'MyReal2.bin'); Rewrite(f2);
var buf:=new real[5];
var b:real;
while not Eof(f1) do begin
// переписываем пять положительных
loop 5 do begin Read(f1,b); Write(f2,b) end;
// считываем пять положительных в буфер
for var i:=0 to 4 do Read(f1,buf[i]);
// переписываем пять отрицательных
loop 5 do begin Read(f1,b); Write(f2,b) end;
// пишем пять положительных из буфера
foreach var t in buf do Write(f2,t);
// переписываем пять отрицательных
loop 5 do begin Read(f1,b); Write(f2,b) end
end;
f1.Close;
// контрольное чтение
f2.Seek(0); // к началу
while not Eof(f2) do begin Read(f2,b); Print(b) end;
Writeln;
f2.Close
end.
Пример
9.7 1 4.1 8.3 5.6 -8.8 -7.7 -1.4 -5.2 -7.2 9.3 2.2 9.3 5.8 8.8 -8.3 -1.3 -8.9 -6.3 -4.8 3.5 3.8 3.2 6 3.2 -8 -0.8 -3.3 -9.5 -7.9 4.5 10 4.5 6.1 0.7 -0.9 -7.4 -9.4 -1.8 -4.6
- 19.08.2018 08:30
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.