Вопрос по информатике:
Дана последовательность из N вещественных чисел. Переменной t присвоить значение true, если в последовательности нет нулевых элементов. Написать программу для Pascal ABC и блок-схему. Студенческий уровень.
- 27.02.2017 20:41
- Информатика
- remove_red_eye 16767
- thumb_up 49
Ответы и объяснения 1
N, i: integer;
x: real;
t: boolean;
begin
readln(N);
i := 0;
repeat
i := i + 1;
Readln(x);
until (x < 0.001) or (i = N);
t := x > 0.001;
writeln(t)
end.
- 28.02.2017 06:17
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.