Вопрос по информатике:
Помогите решить задачу: в массиве хранится информация о среднедневной температуре декабря. Составьте программу, которая подсчитывает, сколько в декабре было дней с нулевой, отрицательной и положительной температурой. Даю 22 балла.
- 08.01.2018 04:42
- Информатика
- remove_red_eye 4303
- thumb_up 38
Ответы и объяснения 2
uses crt;
Var
i,n,k,l:integer;
mA: array[1..31] of real;
begin
ClrScr;
n:=0;
k:=0;
l:=0;
for i:=1 to 31 do
begin
Write('Введите среднедневную температуру ', i,' января: ');
Read(mA[i]);
if mA[i]>0 then n:=n+1;
if mA[i]<0 then k:=k+1;
if mA[i]=0 then l:=l+1;
end;
writeln('Дней с отрицательной температурой: ' ,k);
writeln('Дней с нулевой температурой: ',l);
writeln('Дней с положительной температурой: ',n);
readln;
end.
- 09.01.2018 11:51
- thumb_up 48
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(31,-10,12); a.Println;
Writeln('Дней с нулевой температурой- ',a.Where(t->t=0).Count);
Writeln('Дней с отрицательной температурой- ',a.Where(t->t<0).Count);
Writeln('Дней с положительной температурой- ',a.Where(t->t>0).Count);
end.
Пример
9 -8 0 -10 5 -10 5 -8 -5 8 -2 0 -7 -5 3 6 10 5 -5 1 5 5 10 -3 -3 6 8 7 6 7 12
Дней с нулевой температурой- 2
Дней с отрицательной температурой- 11
Дней с положительной температурой- 18
Если хочется вводить с клавиатуры, вместо строки
var a:=ArrRandom(n,-10,12); a.Println;
надо написать
var a:=ReadArrInteger('Введите температуру по дням'+NewLine,31);
- 01.01.1970 00:00
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.