Вопрос по информатике:
Пожалуйста, напишите программу, которая вводит натуральное число N и определяет его факториал.
Мне нужна программа на языке С++
- 19.06.2016 14:19
- Информатика
- remove_red_eye 11346
- thumb_up 21
Ответы и объяснения 1
#include
using namespace std;
int Factor(int n)
{
if (n == 1)
return 1;
return Factor(n-1)*n;
}
int main()
{
int N;
cin >> N;
cout << Factor(N);
}
Аналог:
#include
using namespace std;
int main()
{
int N;
cin >> N;
int ans = 1;
for (int i = 1; i <= N; ++i)
ans *= i;
cout << ans;
}
- 20.06.2016 05:47
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.