Вопрос по информатике:
Поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8: первое число - номер вертикали (при счете слева направо), второе - номер горизонтали (при счете снизу вверх).
На поле (a, b) расположен король. Верно ли, что он может одним ходом попасть на поле (c, d)?
Чтобы попасть на собственное поле, королю нужно два хода.
Значения c и d могут находится вне границ шахматной доски. В этом случае Король в принципе не может попасть на заданное поле.
Формат входных данных
Даны натуральные числа a, b каждое из которых не превосходит 8.
А также числа c,d каждое из которых лежит в интервале [0, 10]
Формат выходных данных
На выходе программы должно быть написано булево значение, определяющее выполняется ли заданное условие
задача на паскаль
- 27.09.2017 22:46
- Информатика
- remove_red_eye 7206
- thumb_up 26
Ответы и объяснения 1
begin
readln(a,b,c,d);
b1:=(c in [1..8])and(d in [1..8]);
b2:=(abs(a-c)<=1)and(abs(b-d)<=1)and((ac)or(bd));
writeln(b1 and b2);
end.
Пример:
5 4 5 3
True
- 28.09.2017 11:58
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.