Вопрос по информатике:
40 БАЛЛОВ, СРОООООЧНООО. ПОМОГИТЕ ПОЖАЛУЙСТА
1.Выведите на экран кубы n первых натуральных чисел;
2.Составьте программу, которая вычисляет сумму всех четных, двузначных чисел;
3.Дано натуральное число n. Вычислите 3n;
4Дано натуральное число n. Получить наименьшее число вида 2r, превосходящее n.
- 14.07.2018 08:57
- Информатика
- remove_red_eye 2546
- thumb_up 48
Ответы и объяснения 1
var n,i:integer;
begin
readln(n);
for i:=1 to n do writeln(i,' ',i*i*i);
end.
Пример:
4
1 1
2 8
3 27
4 64
2.
var s,i:integer;
begin
s:=0;
for i:=10 to 99 do
if i mod 2=0 then s:=s+i;
writeln('s = ',s);
end.
Результат:
s = 2430
3.
var n:integer;
begin
readln(n);
writeln('3 * ',n,' = ',3*n);
end.
Пример:
5
3 * 5 = 15
4.
var n:integer;
begin
readln(n);
writeln(n+1+(n+1) mod 2);
end.
Пример:
8
10
- 15.07.2018 18:34
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.