Вопрос по информатике:
Помогите составить программу на языке C++!
Дано натуральное число N. Выведите слово YES, если число N является точной степенью двойки, или слово NO в противном случае. Операцией возведения в степень пользоваться нельзя!
- 24.01.2015 00:22
- Информатика
- remove_red_eye 11834
- thumb_up 21
Ответы и объяснения 1
using namespace std;
int main(){
int n;
cin >> n;
if (n <= 0)
{
cout << "NO";
return 0;
}
while (n % 2 == 0)
{
n = n / 2;
}
if ( n == 1)
cout << "YES";
else
cout << "NO";
}
- 24.01.2015 22:43
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.