Вопрос по информатике:
Пожалуйста помогите решить задачу по ИКТ. СРОЧНО!!! 39. Составьте программу вычисления длины боковой стороны равнобедренного треугольника, у которого площадь равна S, а длина основания в три раза больше длины высоты, опущенной на него.
- 02.03.2015 13:26
- Информатика
- remove_red_eye 9582
- thumb_up 21
Ответы и объяснения 2
a = 3*h ⇒ s = 3*h*h/2 ⇒ h = √(2*s/3)
Искомая боковая сторона треугольника - это гипотенуза треугольника со сторонами a/2 (=3*h/2) и h ⇒ b^2 = (3*h/2)^2+h^2
var s,b,h:real;
begin
readln(s);
h:=sqrt(2*s/3); //s:=3*h*h/2
b:=sqrt(13)*h/2; // b^2 =(3*h/2)^2+h^2
writeln('a = ',3*h:5:2,' h = ',h:5:2);
writeln('b = ',b:5:2);
end.
Пример:
16
a = 9.80 h = 3.27
b = 5.89
- 03.03.2015 02:25
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.