Вопрос по информатике:
Написать программу на Си.
Составить программу, определяющую, в каком из данных двух чисел больше цифр.
- 10.02.2016 10:46
- Информатика
- remove_red_eye 8485
- thumb_up 43
Ответы и объяснения 1
int main(void) {
int a1,a2,b,k1=0,k2=0;
printf("a1 = ");
scanf("%d",&a1);
printf("a2 = ");
scanf("%d",&a2);
if (a1>0) b=a1; else b=-a1;
while (b>0) {
k1++; b /= 10;
}
if (a2>0) b=a2; else b=-a2;
while (b>0) {
k2++; b /= 10;
}
if (k1>k2) printf("В числе %d больше цифр, чем в числе %d",a1,a2);
else if (k2>k1) printf("В числе %d больше цифр, чем в числе %d",a2,a1);
else printf("Количество цифр в числах одинаково");
return 0;
}
Пример:
a1 = 153
a2 = -4680
В числе -4680 больше цифр, чем в числе 153
- 11.02.2016 02:23
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.