Вопрос по информатике:
Дан целочисленный массив из 50 элементов. Элементы массива могут принимать значения от –500 до 500. Напишите программу, которая находит и выводит среднее арифметическое всех элементов массива, оканчивающихся цифрой 3
Помогите плз
- 11.10.2017 20:39
- Информатика
- remove_red_eye 16892
- thumb_up 13
Ответы и объяснения 1
begin
var a:=ArrRandom(50,-500,500);
a.Println;
var k:=a.Where(x->(abs(x) mod 10 = 3)).Count;
var s:=a.Where(x->(abs(x) mod 10 = 3)).Sum;
if k=0 then writeln('В массиве нет элементов, оканчивающихся цифрой 3')
else Writeln('Среднее арифметическое элементов массива, оканчивающихся цифрой 3 = ',s/k);
end.
Пример (для 10 элементов):
450 -159 189 463 262 220 -125 -41 -178 -62
Среднее арифметическое элементов массива, оканчивающихся цифрой 3 = 463
- 12.10.2017 02:58
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.