Вопрос по информатике:
Дан массив А состоящий из элементов N массив B состоящий из элементов M составить программу которая меняет порядок элементов на обратный (для ввода печати использовать функцию )в с++
- 20.01.2018 14:17
- Информатика
- remove_red_eye 16160
- thumb_up 10
Ответы и объяснения 1
Потом вводится M и массив b.
Программа выводит перевернутые массивы a и b
Если будут вопросы пиши к комментариям.
#include
using namespace std;
int main(){
int N;
cin >> N;
vector a(N);
for (int i = 0; i < N; i++)
cin >> a[i];
int M;
cin >> M;
vector b(M);
for (int i = 0; i < M; i++)
cin >> b[i];
reverse(a.begin(), a.end());
reverse(b.begin(), b.end());
for (int i = 0; i < N; i++)
cout << a[i] << ' ';
cout << endl;
for (int i = 0; i < M; i++)
cout << b[i] << ' ';
}
- 21.01.2018 21:44
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.