Вопрос по информатике:
Составьте программу на языке Паскаль для решения задачи. С клавиатуры вводятся 5 действительных чисел. Найти сумму всех чисел, больше 5. И произведение всех чисел, меньше 1.
- 08.12.2016 19:02
- Информатика
- remove_red_eye 19608
- thumb_up 47
Ответы и объяснения 1
var
a: array[1..n] of integer;
i,k,s,p:integer;
begin
s:=0;
p:=1;
for i:=1 to n do
begin
readln(a[i]);
if(a[i] >= 5) then
s:=s+a[i] else
if (a[i] <1) then
p:=p*a[i];
end;
writeln('Исходные числа');
for i:=1 to n do
write(a[i]+ ' ');
writeln;
writeln('Сумма чисел больше 5 : ',s:2);
writeln('Произведение меньше 1 : ',p:2);
readln
end.
- 09.12.2016 18:24
- thumb_up 48
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.