Вопрос по информатике:
Написать программу в паскаль ABC, генератор чисел от 0 до 1 с 16 знаками после запятой(пример 0.0000000000000002) и записать эти данные в файл txt по возрастанию.
- 05.07.2018 11:51
- Информатика
- remove_red_eye 7912
- thumb_up 33
Ответы и объяснения 1
var
a:array[1..1000] of real;
i,x, j:integer;
cur:real;
l:text;
label y;
begin
assign(l, 'output.txt');
rewrite(l);
randomize;
for i:= 1 to 999 do
begin
y:
cur := 0.96743612142/( random(24)+random(11)+random(7));
x:= random(100);
if x > 20 then
if cur < 0.4 then cur:= cur * random(5);
if (cur = 0) or (cur > 1)then goto y;
a[i]:=cur;
end;
for i:= 1 to 999 do
for j:= 1 to 999 do
if a[j] > a[i] then swap(a[j], a[i]);
for i:= 1 to 999 do writeln(l, a[i]:0:16);
close(l);
end.
================================================================
Улучшенная версия
var
a: array[1..1000] of real;
i, x, j: integer;
cur, tmp: real;
l: text;
label y, z;
begin
assign(l, 'output.txt');
rewrite(l);
randomize;
for i := 1 to 999 do
begin
y:
tmp := 1 - 1 / (random(33) + random(11) + random(7));
if tmp < 0.4 then goto y;
cur := tmp / abs(random(24) + random(11) - random(7));
if cur > 0.8 then
begin
x := random(10000);
if x < random(10000) then
begin
cur := cur / (1 - 1/(random(10) + random(11) + random(7))); end;
end;
x := random(100);
if x > 50 then
if cur < 0.5 then cur := cur * random(5);
if cur < 0.1 then
begin
x := random(10000);
if x < 7000 then
cur := cur * random(8);
end;
if cur > 0.8 then
cur:= cur - 1/(random(10) + random(11) + random(7)) - 1/(random(10) + random(11) + random(7)) + 1/(random(10) + random(11) + random(7)) + 1/(random(10) + random(11) + random(7));
if (cur = 0) or (cur > 1) then goto y;
a[i] := cur;
end;
for i := 1 to 999 do
for j := 1 to 999 do
if a[j] > a[i] then swap(a[j], a[i]);
for i := 1 to 999 do writeln(l, a[i]:0:16);
close(l);
end.
- 06.07.2018 09:48
- thumb_up 43
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.