Вопрос по информатике:
Написать программу решения квадратных уравнений. Вычисление D оформить процедурой (паскаль).
- 07.09.2018 20:08
- Информатика
- remove_red_eye 13854
- thumb_up 21
Ответы и объяснения 1
procedure p(a,b,c:real; var d:real);
begin
d:=b*b-4*a*c;
end;
begin
readln(a,b,c);
p(a,b,c,d);
if d<0 then writeln('Корней нет')
else if d=0 then writeln('x = ',-b/(2*a):3:1)
else writeln('x1 = ',(-b+d)/(2*a):3:1,' x2 = ',(-b-d)/(2*a):3:1);
end.
Пример:
2 3 1
x1 = -0.5 x2 = -1.0
- 08.09.2018 08:14
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.