Вопрос по информатике:
Программа запускается, но ввожу значения переменных, а ответ не выдаёт.
Не могу понять, в чём проблема?
Занимаюсь недавно, не ругайте))
И правильно ли я её вообще решила?
var
max,x,y,z,t:real;
begin
readln(x,y,z);
if(x>y)then max:=x
else max:=y;
if(z>max)then max:=z;
if(z*max t:=x*x+y*y+z*z-2*sqr(max);
if(t>0)then writeln('acute');
if(t=0)then writeln('right');
if(t<0)then writeln('obtuse')
else writeln('impossible');
end;
readln;
end.
Сама задача, если понадобится
Определите тип треугольника (остроугольный, тупоугольный, прямоугольный) с данными сторонами.
Входные данные
Даны три натуральных числа – стороны треугольника.
Выходные данные
Необходимо вывести одно из слов: right для прямоугольного треугольника, acute для остроугольного треугольника, obtuse для тупоугольного треугольника или impossible, если входные числа не образуют треугольника.
- 15.04.2018 17:48
- Информатика
- remove_red_eye 13585
- thumb_up 21
Ответы и объяснения 1
var
max,x,y,z,t:real;
begin
readln(x,y,z);
if(x>y)then max:=x
else max:=y;
if(z>max)then max:=z;
if(z*max*t=x*x+y*y+z*z-2*sqr(max)) then begin
if(t>0)then writeln('acute');
if(t=0)then writeln('right');
if(t<0)then writeln('obtuse')
end
else writeln('impossible');
readln;
end.
- 16.04.2018 14:19
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.