Вопрос по информатике:
Мой дедюшка дарил мне один доллар на мой первый день рождения. В каждый следующий день рождения он удваивал свой прошлогодний подарок, прибавлял к нему столько долларов, сколько лет мне исполнялось, и полученную сумму дарил мне. написать программу указывающую к какому дню рожденияподарок превысил 100$
написать на C++
- 07.02.2018 02:12
- Информатика
- remove_red_eye 18078
- thumb_up 27
Ответы и объяснения 2
using namespace std;
int main ()
{
int a,i,kol;
a=1; kol=1;
for (i=2; i<10; i++)
{
a+=a*2+i;
kol=kol+1;
if (a>100)
{ break; }
}
cout << kol;
return 0;
}
- 08.02.2018 00:45
- thumb_up 26
using namespace std;
int main ()
{
int k=1, s=1;
while (s<=100) {
k++;
s = s*2+k;
}
cout << k;
return 0;
}
Результат:
6
- 09.02.2018 04:55
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.