Вопрос по информатике:
Составьте программу для паскаля. Даны три числа. Найти среди них произведение и количество отрицательных.
- 17.05.2017 23:38
- Информатика
- remove_red_eye 3496
- thumb_up 42
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadInteger3('Введите три целых числа:');
var (p,k):=(int64(1),0);
if a<0 then begin p:=p*a; k+=1 end;;
if b<0 then begin p:=p*b; k+=1 end;
if c<0 then begin p:=p*c; k+=1 end;
Writeln('Произведение чисел равно ',p);
Writeln('Количество отрицательных чисел равно ',k);
end.
Пример
Введите три целых числа: 12345 -67891011 -1213141516
Произведение чисел равно 82361404007312676
Количество отрицательных чисел равно 2
- 18.05.2017 20:29
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.