Вопрос по информатике:
Задан одномерный числовой массив.напишите программу которая находит второй по величене после максимльного элемент и его номер . решение паскаль
- 08.08.2018 03:39
- Информатика
- remove_red_eye 5736
- thumb_up 29
Ответы и объяснения 1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
var s:=a.Distinct.OrderBy(x->x).Reverse.Skip(1);
if s.Count>0 then begin
var i:=a.FindIndex(t->t=s.First);
Writeln('Искомый элемент равен ',a[i],' его порядковый номер ',i+1)
end
else Writeln('Нет искомых элементов')
end.
Пример
n= 13
-7 -2 -32 9 21 -31 34 -34 27 -35 11 7 -10
Искомый элемент равен 27 его порядковый номер 9
- 09.08.2018 11:45
- thumb_up 41
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.